blob: 126e34c38293304cf99153b7f43548bd7b9dbe13 [file] [log] [blame]
Serge Bazanski2efb6982020-10-03 00:13:45 +02001{ ... }@args:
2
3with builtins;
4
5let
6 fix = f: let x = f x; in x;
7
Bartosz Stebel56ff18c2021-08-30 23:28:45 +02008 readTree = import ./nix/readtree {};
Serge Bazanski2efb6982020-10-03 00:13:45 +02009
Serge Bazanskic31887e2021-08-11 16:47:36 +000010 # Tracking nixos-unstable as of 2021-08-11.
Patryk Jakuszew28742b82022-11-26 21:33:38 +010011 nixpkgsCommit = "42aae6fa748a41ced37373fc6d914de512658178";
Serge Bazanski2efb6982020-10-03 00:13:45 +020012 nixpkgsSrc = fetchTarball {
Serge Bazanski225a5c72021-02-13 13:15:57 +010013 url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
Patryk Jakuszew28742b82022-11-26 21:33:38 +010014 sha256 = "I7oAGC1Ldm5kcryUQxLubMmMCj5o0n+JSLVGRCL0wm8=";
Serge Bazanski2efb6982020-10-03 00:13:45 +020015 };
16 nixpkgs = import nixpkgsSrc {
17 config.allowUnfree = true;
18 config.allowBroken = true;
Patryk Jakuszew28742b82022-11-26 21:33:38 +010019
20 # Nixpkgs marked this package as insecure.
21 # We need it for HTML-to-PDF conversion.
22 config.permittedInsecurePackages = [
23 "qtwebkit-5.212.0-alpha4"
24 ];
Serge Bazanski2efb6982020-10-03 00:13:45 +020025 };
26
Serge Bazanskic35ea6a2022-07-07 17:47:58 +020027 resForPkgs = pkgs: fix (self: (readTree rec {
28 hscloud = self;
29 inherit pkgs;
30 pkgsSrc = pkgs.path;
31 inherit (pkgs) lib stdenv;
32 hscloudForPkgs = pkgs: resForPkgs pkgs;
33 } ./.));
34
35in (resForPkgs nixpkgs) // {
Bartosz Stebel56ff18c2021-08-30 23:28:45 +020036 root = ./.;
Serge Bazanski2efb6982020-10-03 00:13:45 +020037 pkgs = nixpkgs;
Serge Bazanskic35ea6a2022-07-07 17:47:58 +020038}