ops: inject the machine's pkgs into the machine's hscloud tree

This ensures, for example, that the packets are for the correct
architecture.

Change-Id: If17c307fbad02ee72c6dd21a874c59514415ab2e
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1334
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/default.nix b/default.nix
index f06a4d3..d3eb869 100644
--- a/default.nix
+++ b/default.nix
@@ -18,12 +18,15 @@
     config.allowBroken = true;
   };
 
-in fix (self: (readTree rec {
-  hscloud = self;
-  pkgs = nixpkgs;
-  pkgsSrc = nixpkgsSrc;
-  inherit (nixpkgs) lib stdenv;
-} ./.) // {
+  resForPkgs = pkgs: fix (self: (readTree rec {
+    hscloud = self;
+    inherit pkgs;
+    pkgsSrc = pkgs.path;
+    inherit (pkgs) lib stdenv;
+    hscloudForPkgs = pkgs: resForPkgs pkgs;
+  } ./.));
+
+in (resForPkgs nixpkgs) // {
   root = ./.;
   pkgs = nixpkgs;
-})
+}