blob: c284030886dd8e7cce3c11943ccbe19d417178fe [file] [log] [blame]
Serge Bazanski2efb6982020-10-03 00:13:45 +02001{ ... }@args:
2
3with builtins;
4
5let
6 fix = f: let x = f x; in x;
7
8 readTree = import ./nix/readtree.nix {};
9
10 # Tracking nixos-unstable as of 2020-08-22.
11 nixpkgsCommit = "c59ea8b8a0e7f927e7291c14ea6cd1bd3a16ff38";
12 nixpkgsSrc = fetchTarball {
13 url = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsCommit}.tar.gz";
14 sha256 = "1ak7jqx94fjhc68xh1lh35kh3w3ndbadprrb762qgvcfb8351x8v";
15 };
16 nixpkgs = import nixpkgsSrc {
17 config.allowUnfree = true;
18 config.allowBroken = true;
19 };
20
21in fix (self: rec {
22 config = {
23 hscloud = self // {
24 root = ./.;
25 };
26 pkgs = nixpkgs;
27 pkgsSrc = nixpkgsSrc;
28
29 inherit (nixpkgs) lib stdenv;
30 };
31
32 bgpwtf = readTree config ./bgpwtf;
33 cluster = readTree config ./cluster;
34 ops = readTree config ./ops;
35
36 pkgs = nixpkgs;
37})