default.nix: bump nixpkgs

This fixes some issues with buildFHSUserEnv on newer NixOSes, where
stuff from the /run/current-system/sw/bin/* would want a newer glibc
than the glibc available in the FSHUserEnv. Whoops.

Change-Id: I5ed741b6d7979eb288fe6f88984bc5e6d0bdb923
diff --git a/default.nix b/default.nix
index 4540157..6d9c0c4 100644
--- a/default.nix
+++ b/default.nix
@@ -7,11 +7,11 @@
 
   readTree = import ./nix/readtree.nix {};
 
-  # Tracking nixos-unstable as of 2021-01-31.
-  nixpkgsCommit = "44ad80ab1036c5cc83ada4bfa451dac9939f2a10";
+  # Tracking nixos-unstable as of 2021-08-11.
+  nixpkgsCommit = "e26c0ffdb013cd378fc2528a44689a8bf35d2a6c";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "1b61nzvy0d46cspy07szkc0rggacxiqg9v1py27pkqpj7rvawfsk";
+    sha256 = "1b33hw35fqb9rzszdg5jpiyfvhx2cxpv0qrkyr19zkdpdahzdbss";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;