blob: 6d9c0c4ff3f3f92992d645aa9a2f632fa4495aef [file] [log] [blame]
Serge Bazanski2efb6982020-10-03 00:13:45 +02001{ ... }@args:
2
3with builtins;
4
5let
6 fix = f: let x = f x; in x;
7
8 readTree = import ./nix/readtree.nix {};
9
Serge Bazanskic31887e2021-08-11 16:47:36 +000010 # Tracking nixos-unstable as of 2021-08-11.
11 nixpkgsCommit = "e26c0ffdb013cd378fc2528a44689a8bf35d2a6c";
Serge Bazanski2efb6982020-10-03 00:13:45 +020012 nixpkgsSrc = fetchTarball {
Serge Bazanski225a5c72021-02-13 13:15:57 +010013 url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
Serge Bazanskic31887e2021-08-11 16:47:36 +000014 sha256 = "1b33hw35fqb9rzszdg5jpiyfvhx2cxpv0qrkyr19zkdpdahzdbss";
Serge Bazanski2efb6982020-10-03 00:13:45 +020015 };
16 nixpkgs = import nixpkgsSrc {
17 config.allowUnfree = true;
18 config.allowBroken = true;
19 };
20
21in fix (self: rec {
22 config = {
23 hscloud = self // {
24 root = ./.;
25 };
26 pkgs = nixpkgs;
27 pkgsSrc = nixpkgsSrc;
28
29 inherit (nixpkgs) lib stdenv;
30 };
31
32 bgpwtf = readTree config ./bgpwtf;
33 cluster = readTree config ./cluster;
Serge Bazanskib1de7572020-10-29 00:43:43 +010034 hswaw = readTree config ./hswaw;
Serge Bazanski2efb6982020-10-03 00:13:45 +020035 ops = readTree config ./ops;
36
37 pkgs = nixpkgs;
38})