blob: e9090608369123aa87f3310b0bcc564195dd8f0c [file] [log] [blame]
Serge Bazanski5ac5e4b2022-07-06 00:31:35 +02001# Aarch64 builder in Oracle Cloud, managed by q3k. Add your keys/users to have
2# access to this machine. An Aarch64 remote builder is required when
3# crosscompiling for aarch64.
4
5{ pkgs, ... }: {
6 imports = [
7 ./hardware-configuration.nix
8 ];
9
10 boot.cleanTmpDir = true;
11 zramSwap.enable = true;
12 networking.hostName = "larrythebuilder";
13 networking.domain = "q3k.org";
14 environment.systemPackages = with pkgs; [
15 vim rxvt-unicode-unwrapped.terminfo
16 ];
17 services.openssh.enable = true;
18 users.users.q3k = {
19 isNormalUser = true;
20 openssh.authorizedKeys.keys = [
21 "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG599UildOrAq+LIOQjKqtGMwjgjIxozI1jtQQRKHtCP q3k@mimeomia"
22 ];
23 };
Piotr Dobrowolski36ce7642022-07-07 02:11:13 +020024
25 users.users.informatic = {
26 isNormalUser = true;
27 openssh.authorizedKeys.keys = [
28 "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDoKB2p/gFaKthQNXeQvSLzhOlLSq3vjVL3AEOBTMXGH informatic@atuin"
29 ];
30 };
31
Serge Bazanski5ac5e4b2022-07-06 00:31:35 +020032 users.users.root.openssh.authorizedKeys.keys = [
33 "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG599UildOrAq+LIOQjKqtGMwjgjIxozI1jtQQRKHtCP q3k@mimeomia"
Piotr Dobrowolski36ce7642022-07-07 02:11:13 +020034 "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDoKB2p/gFaKthQNXeQvSLzhOlLSq3vjVL3AEOBTMXGH informatic@atuin"
Serge Bazanski5ac5e4b2022-07-06 00:31:35 +020035 ];
36}