hswaw/machines: add tv1, larrythebuilder

This adds two brand new AArch64 machines: a generic builder (and
instructions on how to use it) and tv1.waw, an RPi4 acting as digital
signage in the space.

Change-Id: I8d38344ec35f99f4b872cf9526f6e6771fbffc43
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1330
Reviewed-by: informatic <informatic@hackerspace.pl>
diff --git a/hswaw/machines/larrythebuilder.q3k.org/configuration.nix b/hswaw/machines/larrythebuilder.q3k.org/configuration.nix
new file mode 100644
index 0000000..e18deac
--- /dev/null
+++ b/hswaw/machines/larrythebuilder.q3k.org/configuration.nix
@@ -0,0 +1,27 @@
+# Aarch64 builder in Oracle Cloud, managed by q3k. Add your keys/users to have
+# access to this machine. An Aarch64 remote builder is required when
+# crosscompiling for aarch64.
+
+{ pkgs, ... }: {
+  imports = [
+    ./hardware-configuration.nix
+  ];
+
+  boot.cleanTmpDir = true;
+  zramSwap.enable = true;
+  networking.hostName = "larrythebuilder";
+  networking.domain = "q3k.org";
+  environment.systemPackages = with pkgs; [
+    vim rxvt-unicode-unwrapped.terminfo
+  ];
+  services.openssh.enable = true;
+  users.users.q3k = {
+    isNormalUser = true;
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG599UildOrAq+LIOQjKqtGMwjgjIxozI1jtQQRKHtCP q3k@mimeomia" 
+    ];
+  };
+  users.users.root.openssh.authorizedKeys.keys = [
+    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIG599UildOrAq+LIOQjKqtGMwjgjIxozI1jtQQRKHtCP q3k@mimeomia" 
+  ];
+}