blob: f68838c9165d6058c8f05c9ed2a2fa2354e58fc6 [file] [log] [blame]
Bartosz Stebel9a88f282023-10-08 22:26:20 +02001{ config, pkgs, ... }:
2
3with builtins;
4
5rec {
6 networking.hostName = "dcr03s16";
7 # TODO: undefine fqdn and define domain after big nix change
8 hscloud.base.fqdn = "${networking.hostName}.hswaw.net";
9 #networking.domain = "hswaw.net";
10 system.stateVersion = "22.05";
11 nix.maxJobs = 48;
12
Bartosz Stebel9a88f282023-10-08 22:26:20 +020013 fileSystems."/".device = "/dev/vg-nixos-hscloud/nixos-root";
14 #services.lvm.enable = true;
15 fileSystems."/boot1" =
16 { device = "/dev/disk/by-partuuid/4aaabcc2-6efa-499d-890a-553228917416";
17 fsType = "vfat";
18 };
19 fileSystems."/boot2" =
20 { device = "/dev/disk/by-partuuid/cd6c0ffb-0119-4dce-a15a-ad5639eb5eb1";
21 fsType = "vfat";
22 };
23
24 boot.loader.systemd-boot.enable = false;
25 boot.loader.efi.canTouchEfiVariables = true;
26 boot.loader.grub = {
27 enable = true;
28 version = 2;
29 efiSupport = true;
30 mirroredBoots = [
31 { devices = [ "nodev" ]; path = "/boot1"; efiSysMountPoint = "/boot1"; }
32 { devices = [ "nodev" ]; path = "/boot2"; efiSysMountPoint = "/boot2"; }
33 ];
34 };
Bartosz Stebel9a88f282023-10-08 22:26:20 +020035
36
37 hscloud.base = {
38 mgmtIf = "enp5s0";
39 ipAddr = "185.236.240.45";
40 ipAddrBits = 28;
41 gw = "185.236.240.33";
42 };
Bartosz Stebel9a88f282023-10-08 22:26:20 +020043 hscloud.kube = {
Bartosz Stebelbae94992023-10-09 21:02:07 +020044 control.enable = true;
Bartosz Stebel9a88f282023-10-08 22:26:20 +020045 data.enable = true;
46 data.podNet = "10.10.21.0/24";
47 };
48}
49