Serge Bazanski | 55a486a | 2022-06-11 18:27:01 +0000 | [diff] [blame] | 1 | { config, pkgs, ... }: |
| 2 | |
| 3 | with builtins; |
| 4 | |
| 5 | rec { |
| 6 | networking.hostName = "bc01n01"; |
| 7 | # TODO: undefine fqdn and define domain after big nix change |
| 8 | hscloud.base.fqdn = "${networking.hostName}.hswaw.net"; |
| 9 | #networking.domain = "hswaw.net"; |
| 10 | system.stateVersion = "18.09"; |
| 11 | nix.maxJobs = 16; |
| 12 | |
| 13 | boot.loader.grub.device = "/dev/disk/by-id/scsi-360024e8078a9060023b1043107388af5"; |
| 14 | fileSystems."/".device = "/dev/disk/by-uuid/518ecac1-00ea-4ef0-9418-9eca6ce6d918"; |
| 15 | |
| 16 | hscloud.base = { |
| 17 | mgmtIf = "eno1"; |
| 18 | ipAddr = "185.236.240.35"; |
| 19 | ipAddrBits = 28; |
| 20 | gw = "185.236.240.33"; |
| 21 | }; |
| 22 | |
Bartosz Stebel | bae9499 | 2023-10-09 21:02:07 +0200 | [diff] [blame] | 23 | hscloud.kube.control.enable = false; |
Serge Bazanski | 55a486a | 2022-06-11 18:27:01 +0000 | [diff] [blame] | 24 | hscloud.kube.data = { |
Serge Bazanski | 43b6db8 | 2023-10-09 22:42:30 +0000 | [diff] [blame] | 25 | enable = false; |
Serge Bazanski | 55a486a | 2022-06-11 18:27:01 +0000 | [diff] [blame] | 26 | podNet = "10.10.16.0/24"; |
| 27 | }; |
| 28 | |
Serge Bazanski | 55a486a | 2022-06-11 18:27:01 +0000 | [diff] [blame] | 29 | environment.systemPackages = [ |
| 30 | pkgs.shadow |
| 31 | ]; |
| 32 | } |
| 33 | |