blob: c93048ac655e8dea5124697d4ce1f4e8fbdb5c6f [file] [log] [blame]
Serge Bazanski6abe4fa2020-10-03 00:18:34 +02001# Hardware configuration of edge01. Generated by nixos-generate-config.
2
3{ config, lib, pkgs, modulesPath, ... }:
4
5{
6 imports =
7 [ (modulesPath + "/installer/scan/not-detected.nix")
8 ];
9
10 boot.initrd.availableKernelModules = [ "ahci" "usb_storage" "usbhid" ];
11 boot.initrd.kernelModules = [ "dm-snapshot" ];
12 boot.kernelModules = [ "kvm-intel" ];
13 boot.extraModulePackages = [ ];
14 system.stateVersion = "20.03";
15 boot.loader.systemd-boot.enable = true;
16 boot.loader.efi.canTouchEfiVariables = true;
17
18
19 fileSystems."/" =
20 { device = "/dev/disk/by-uuid/b1b85556-8f3b-4695-8ad5-2159c93c76de";
21 fsType = "ext4";
22 };
23
24 fileSystems."/boot" =
25 # Pendrive.
26 # Real boot is at D8BA-345D.
27 { device = "/dev/disk/by-uuid/D8BA-345D";
28 fsType = "vfat";
29 };
Bartosz Stebelc7267982020-12-10 15:38:29 +010030 hscloud.anchorvm.blkdev = "/dev/janusz-vg/ripeanchor";
Serge Bazanski6abe4fa2020-10-03 00:18:34 +020031
32 swapDevices =
33 [ { device = "/dev/disk/by-uuid/5dadcff4-fcd4-4e8d-81f6-be68fb630396"; }
34 ];
35
36 powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
37}