blob: 742a5413bc8d5553651abb8272ffdbde3a09124f [file] [log] [blame]
Serge Bazanski55a486a2022-06-11 18:27:01 +00001{ config, pkgs, ... }:
2
3with builtins;
4
5rec {
6 networking.hostName = "dcr01s22";
7 # TODO: undefine fqdn and define domain after big nix change
8 hscloud.base.fqdn = "${networking.hostName}.hswaw.net";
9 #networking.domain = "hswaw.net";
10 system.stateVersion = "19.09";
11 nix.maxJobs = 48;
12
13 boot.loader.grub.device = "/dev/disk/by-id/ata-Samsung_SSD_860_EVO_250GB_S3YJNX1M604518E";
14 fileSystems."/".device = "/dev/disk/by-uuid/b4149083-49fe-4951-a143-aff4cedaf33a";
15
16 hscloud.base = {
17 mgmtIf = "enp130s0f0";
18 ipAddr = "185.236.240.39";
19 ipAddrBits = 28;
20 gw = "185.236.240.33";
21 };
22
23 hscloud.kube = {
24 control.enable = true;
25 data.enable = true;
26 data.podNet = "10.10.19.0/24";
27 };
28
29 hscloud.ceph = {
30 name = "k0";
31 fsid = "74592dc2-31b7-4dbe-88cf-40459dfeb354";
32
33 osd.devices = [
34 { id = 0; path = "/dev/disk/by-id/scsi-35000c500850293e3"; uuid = "314034c5-474c-4d0d-ba41-36a881c52560";}
35 { id = 1; path = "/dev/disk/by-id/scsi-35000c500850312cb"; uuid = "a7f1baa0-0fc3-4ab1-9895-67abdc29de03";}
36 { id = 2; path = "/dev/disk/by-id/scsi-35000c5008508e3ef"; uuid = "11ac8316-6a87-48a7-a0c7-74c3cef6c2fa";}
37 { id = 3; path = "/dev/disk/by-id/scsi-35000c5008508e23f"; uuid = "c6b838d1-b08c-4788-936c-293041ed2d4d";}
38 ];
39 };
40}
41