blob: 01157fd62fbc58a5c47cba55341a0a8870496dc0 [file] [log] [blame]
Piotr Dobrowolskia01905a2021-10-16 18:22:46 +02001{ pkgs ? import <nixpkgs> {} }:
2
3pkgs.stdenv.mkDerivation {
4 name = "ulogd2";
5
6 buildInputs = with pkgs; [
7 gnumake libnetfilter_acct libnetfilter_conntrack libnetfilter_log libmnl
8 libnfnetlink automake autoconf autogen libtool pkg-config libpcap
9 ];
10
11 # hack to capture TCP and UDP port numbers (first 8 bytes) but omit rest of payload
12 patches = [ ./onlyports.patch ];
13
14 preConfigure = ''
15 echo running autogen
16 ./autogen.sh
17 autoheader
18 automake --force-missing --add-missing
19 ./configure --help
20 '';
21
22 src = pkgs.fetchgit {
23 url = "https://git.netfilter.org/ulogd2/";
24 rev = "63135e73fd878cb71b1eebf8e877c4d4c34feba7";
25 sha256 = "1ccfb8l7q9k4fy9s0sgab49ma9xphr4x4ap0v52xfrnwx57h87s2";
26 };
27}