blob: 4135f7a7f852577f12fb022c1be723915de55917 [file] [log] [blame]
Piotr Dobrowolski6c69fcd2021-10-17 00:32:25 +02001{ pkgs }:
2
3let
4 spaceauth = pkgs.callPackage "${pkgs.fetchgit {
5 url = "https://code.hackerspace.pl/informatic/flask-spaceauth";
6 rev = "d3e1a4412cbc929249e407ccecfb54fbbd14e53a";
7 sha256 = "01qnjj647jw81hcyvq359rwqjpc5ah9ghvc6ic0a0wppp13mgw94";
8 }}" {};
9in pkgs.python3Packages.buildPythonPackage {
10 pname = "checkinator";
11 version = "0.2";
12
13 doCheck = false;
14 src = pkgs.fetchgit (builtins.fromJSON (builtins.readFile ./checkinator-repo.json));
15
16 patches = [
17 ./checkinator-werkzeug.patch
18 ];
19
20 postInstall = ''
21 cp -r dbsetup.sql $out/dbsetup.sql
22 cp -r static $out/static
23 '';
24
25 propagatedBuildInputs = with pkgs; [
26 python3Packages.gunicorn
27 python3Packages.flask
28 python3Packages.pyyaml
29 python3Packages.isodate
30 python3Packages.requests
31 python3Packages.requests-unixsocket
32 python3Packages.grpcio
33 python3Packages.grpcio-tools
34 python3Packages.setuptools
35 python3Packages.protobuf
36 spaceauth
37 iproute
38 ];
39}