blob: 09f2555f5d2dd5471973b1c27b8c4688e3b5e095 [file] [log] [blame]
Serge Bazanski6abe4fa2020-10-03 00:18:34 +02001# Functionality that used to live in bootstrap.hswaw.net, a VM.
2# PXE boot support has been removed and the functionality moved back to
3# edge01.waw.bgp.wtf.
4
5{ config, pkgs, ... }: {
6 networking.bridges.bootstrap.interfaces = [];
7 networking.interfaces.bootstrap.ipv4.addresses = [
8 { address = "185.236.240.18"; prefixLength = 32; }
9 ];
10 services.dhcpd4 = {
11 enable = true;
12 interfaces = [ "bootstrap" "vl-dcsw-l3" ];
13 extraConfig = ''
14 # ISC DHCP is trash. We only use it in relay mode, yet we have to do
15 # this.
16 subnet 185.236.240.18 netmask 255.255.255.255 {}
17
18 subnet 185.236.240.6 netmask 255.255.255.254 {}
19
20 subnet 185.236.240.24 netmask 255.255.255.248 {
21 option routers 185.236.240.25;
22 range 185.236.240.29 185.236.240.30;
23 option domain-name-servers 8.8.8.8;
24 }
25
26 subnet 185.236.240.32 netmask 255.255.255.240 {
27 range 185.236.240.45 185.236.240.46;
28 option routers 185.236.240.33;
29 option domain-name-servers 8.8.8.8;
30 }
31
32 host bc01n01 {
33 hardware ethernet 00:23:ae:fe:83:20;
34 fixed-address 185.236.240.35;
35 option host-name "bc01n01";
36 }
37 host bc01n02 {
38 hardware ethernet 00:23:ae:fe:83:c4;
39 fixed-address 185.236.240.36;
40 option host-name "bc01n02";
41 }
42 host bc01n03 {
43 hardware ethernet 00:23:ae:fe:42:80;
44 fixed-address 185.236.240.37;
45 option host-name "bc01n03";
46 }
47 host boston-packets {
48 hardware ethernet 00:23:ae:fe:45:8c;
49 fixed-address 185.236.240.38;
50 option host-name "boston-packets.hackerspace.pl";
51 #filename "ipxe.efi";
52 }
53 host dcr01s22 {
54 hardware ethernet 90:1b:0e:08:12:b8;
55 fixed-address 185.236.240.39;
56 option host-name "dcr01s22";
57 #filename "ipxe.efi";
58 }
59 host dcr01s24 {
60 hardware ethernet 90:1b:0e:31:bb:6a;
61 fixed-address 185.236.240.40;
62 option host-name "dcr01s24";
63 #filename "ipxe.efi";
64 }
65 host dsctf {
66 hardware ethernet 00:23:ae:fe:45:50;
67 fixed-address 185.236.240.41;
68 option host-name "dsctf";
69 }
70 host dcr03s32b1 {
71 hardware ethernet 02:01:87:4a:9a:b9;
72 fixed-address 185.236.240.26;
73 option host-name "dcr03s32b1";
74 }
75 '';
76 };
77}