blob: 29f0ae70345f352c7fbf867abec294ecf2d66837 [file] [log] [blame]
Serge Bazanski5ac5e4b2022-07-06 00:31:35 +02001# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports =
8 [ (modulesPath + "/installer/scan/not-detected.nix")
9 ];
10
11 boot.initrd.availableKernelModules = [ "xhci_pci" "usbhid" ];
12 boot.initrd.kernelModules = [ ];
13 boot.kernelModules = [ ];
14 boot.extraModulePackages = [ ];
15
16 fileSystems."/" =
17 { device = "/dev/disk/by-uuid/44444444-4444-4444-8888-888888888888";
18 fsType = "ext4";
19 };
20
21 swapDevices = [ ];
22
23 # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
24 # (the default) this is the recommended approach. When using systemd-networkd it's
25 # still possible to use this option, but it's recommended to use it in conjunction
26 # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
27 networking.useDHCP = lib.mkDefault true;
28 # networking.interfaces.eth0.useDHCP = lib.mkDefault true;
29 # networking.interfaces.wlan0.useDHCP = lib.mkDefault true;
30
31 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
32}