blob: c3ad18e609646a45bc5619600923da5e3879a227 [file] [log] [blame]
Serge Bazanski55a486a2022-06-11 18:27:01 +00001{ config, pkgs, ... }:
2
3with builtins;
4
5rec {
6 networking.hostName = "dcr01s24";
7 # TODO: undefine fqdn and define domain after big nix change
8 hscloud.base.fqdn = "${networking.hostName}.hswaw.net";
9 #networking.domain = "hswaw.net";
10 system.stateVersion = "19.09";
11 nix.maxJobs = 48;
12
13 boot.loader.grub.device = "/dev/disk/by-id/ata-Samsung_SSD_860_EVO_250GB_S3YJNF0M717009H";
14 fileSystems."/".device = "/dev/disk/by-uuid/fc5c6456-5bbd-4b9e-a93e-7f9073ffe09a";
15
16 hscloud.base = {
17 mgmtIf = "enp130s0f0";
18 ipAddr = "185.236.240.40";
19 ipAddrBits = 28;
20 gw = "185.236.240.33";
21 };
22
23 hscloud.kube = {
24 control.enable = true;
25 data.enable = true;
26 data.podNet = "10.10.20.0/24";
27 };
28
29 hscloud.ceph = {
30 name = "k0";
31 fsid = "74592dc2-31b7-4dbe-88cf-40459dfeb354";
32
33 osd.devices = [
34 { id = 4; path = "/dev/disk/by-id/scsi-35000c5008509199b"; uuid = "a2b4663d-bd8f-49b3-b0b0-195c56ba252f";}
35 { id = 5; path = "/dev/disk/by-id/scsi-35000c50085046abf"; uuid = "a2242989-ccce-4367-8813-519b64b5afdb";}
36 { id = 6; path = "/dev/disk/by-id/scsi-35000c5008502929b"; uuid = "7deac89c-22dd-4c2b-b3cc-43ff7f990fd6";}
37 { id = 7; path = "/dev/disk/by-id/scsi-35000c5008502a323"; uuid = "e305ebb3-9cac-44d2-9f1d-bbb72c8ab51f";}
38 ];
39 };
40}
41