blob: 2fd9ea0c284c496294a3f400cd40265f53db5b4e [file] [log] [blame]
Serge Bazanski55a486a2022-06-11 18:27:01 +00001{ config, pkgs, ... }:
2
3with builtins;
4
5rec {
6 networking.hostName = "dcr01s22";
7 # TODO: undefine fqdn and define domain after big nix change
8 hscloud.base.fqdn = "${networking.hostName}.hswaw.net";
9 #networking.domain = "hswaw.net";
10 system.stateVersion = "19.09";
11 nix.maxJobs = 48;
12
Bartosz Stebel8edc52e2023-11-03 01:47:23 +010013
Bartosz Stebel8edc52e2023-11-03 01:47:23 +010014 fileSystems."/".device = "/dev/vg-nixos-hscloud/nixos-root";
15
Bartosz Stebelf47d3592023-11-03 19:27:28 +010016 fileSystems."/boot1" =
17 { device = "/dev/disk/by-partuuid/86610640-6d3c-423d-8c2d-011f32393a67";
18 fsType = "vfat";
19 };
20 fileSystems."/boot2" =
21 { device = "/dev/disk/by-partuuid/4bb9ddf4-cd1c-4d9f-9f4a-a20bb40d8040";
22 fsType = "vfat";
23 };
24 boot.loader.systemd-boot.enable = false;
25 boot.loader.efi.canTouchEfiVariables = true;
26 boot.loader.grub = {
27 enable = true;
28 version = 2;
29 efiSupport = true;
30 mirroredBoots = [
31 { devices = [ "nodev" ]; path = "/boot1"; efiSysMountPoint = "/boot1"; }
32 { devices = [ "nodev" ]; path = "/boot2"; efiSysMountPoint = "/boot2"; }
33 ];
34 };
35
Serge Bazanski55a486a2022-06-11 18:27:01 +000036
37 hscloud.base = {
38 mgmtIf = "enp130s0f0";
39 ipAddr = "185.236.240.39";
40 ipAddrBits = 28;
41 gw = "185.236.240.33";
42 };
43
44 hscloud.kube = {
45 control.enable = true;
46 data.enable = true;
47 data.podNet = "10.10.19.0/24";
48 };
Serge Bazanski55a486a2022-06-11 18:27:01 +000049}
50