nix/cluster-configuration: fix CNI plugins being deleted on kubelet restart
diff --git a/nix/cluster-configuration.nix b/nix/cluster-configuration.nix
index eb67095..c48761a 100644
--- a/nix/cluster-configuration.nix
+++ b/nix/cluster-configuration.nix
@@ -235,4 +235,11 @@
   systemd.services.kubelet-online = {
     script = pkgs.lib.mkForce "sleep 1";
   };
+  # This by default removes all CNI plugins and replaces them with nix-defines ones
+  # Since we bring our own CNI plugins via containers with host mounts, this causes
+  # them to be removed on kubelet restart.
+  # TODO(q3k): file issue
+  systemd.services.kubelet = {
+    preStart = pkgs.lib.mkForce "sleep 1";
+  };
 }