env.sh: do not set CC=clang in nix(os)

That seems to be broken:

  external/com_google_absl/absl/base/config.h:56:10: fatal error: 'cstddef' file not found

We should probably make it work some day, but let's unbreak things
first.

Change-Id: I5bc6892f8c6353a626f5ca103805c9a0e9a0d494
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1726
Reviewed-by: informatic <informatic@hackerspace.pl>
diff --git a/shell.nix b/shell.nix
index 10dd95c..1ef9301 100644
--- a/shell.nix
+++ b/shell.nix
@@ -20,6 +20,7 @@
     export NIX_SSL_CERT_FILE="${cacert}/etc/ssl/certs/ca-bundle.crt"
     export SSL_CERT_FILE="${cacert}/etc/ssl/certs/ca-bundle.crt"
     export FONTCONFIG_FILE="${fontconfig}"
+    export HSCLOUD_NIX=yes
 
     source ${toString ./.}/env.sh