java: use JDK 11

This is needed for newer versions of the gerrit owners plugin.

We also need to add zlib to our shell, as binary builds of JDK11 used by
Bazel require it.

Change-Id: Idbbc5e0d88cac13daf2e5f201be6032412bf1a5d
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1641
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/shell.nix b/shell.nix
index 6be64bd..10dd95c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -65,6 +65,7 @@
     vim
     openssh
     libxcrypt
+    zlib
   ];
   multiPkgs = pkgs: [
     (pkgs.runCommand "protocols" {}