shell.nix: add missing tools

Some tools were taken from "host" shell/PATH which crashed in certain
cases due to libc incompatiblity.

Fixes b/50

Change-Id: Ie94e2c064afff6d5aa782f70e0a024365079e4c7
diff --git a/shell.nix b/shell.nix
index de3db3c..14395af 100644
--- a/shell.nix
+++ b/shell.nix
@@ -28,6 +28,8 @@
     pwgen
     tmate
     git
+    which
+    nettools
   ];
   multiPkgs = pkgs: [
     (pkgs.runCommand "protocols" {}