shell.nix: actually add

This should've been merged in with cr/704. Whoops.

Change-Id: I1fe18a74462e8bdc0350c5ba26b51261b76c7ae1
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..cb39fe4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,36 @@
+# Shell for being able to use bazel on NixOS (or on any operating system with Nix installed).
+
+let
+
+  hscloud = import ./default.nix {};
+
+in with hscloud.config.pkgs; let
+
+  wrapper = pkgs.writeScript "wrapper.sh"
+  ''
+    source /etc/profile
+    source ${toString ./.}/env.sh
+    ${toString ./.}/tools/install.sh
+
+    exec bash "$@"
+  '';
+
+in (pkgs.buildFHSUserEnv {
+  name = "hscloud-build";
+  targetPkgs = pkgs: with pkgs; [
+    bazel
+    postgresql
+    python38
+    openjdk11
+    openldap.dev cyrus_sasl.dev # for python-ldap
+    wkhtmltopdf
+  ];
+  multiPkgs = pkgs: [
+    (pkgs.runCommand "protocols" {}
+      ''
+      mkdir -p $out/etc
+      ln -s ${pkgs.iana-etc}/etc/protocols $out/etc/protocols
+      '')
+  ];
+  runScript = wrapper;
+}).env