ops: inject the machine's pkgs into the machine's hscloud tree

This ensures, for example, that the packets are for the correct
architecture.

Change-Id: If17c307fbad02ee72c6dd21a874c59514415ab2e
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1334
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/ops/machines.nix b/ops/machines.nix
index 6a95573..5d09d74 100644
--- a/ops/machines.nix
+++ b/ops/machines.nix
@@ -5,7 +5,7 @@
 #
 # For information about building/deploying machines see //ops/README.md.
 
-{ hscloud, pkgs, ... }:
+{ hscloud, pkgs, hscloudForPkgs, ... }:
 
 let
   # nixpkgs for cluster machines (.hswaw.net). Currently pinned to an old
@@ -121,7 +121,7 @@
       passthru.hscloud.provision = pkgs.writeScript "provision-${fqdn}" runProvision;
 
       # TODO(q3k): this should be named hscloud, but that seems to not work. Debug and rename.
-      _module.args.workspace = hscloud;
+      _module.args.workspace = hscloudForPkgs pkgs;
       _module.args.machines = machines;
     };
   });