cluster: use static addresses

This disables DHCP on all k0 nodes. This change has been tentatively
deployed to bc01n01 (which is cordoned off in kube), and I will deploy
it to the rest of k0 machines once merged.

Change-Id: I96253a9d0acedb4512c877c64174992ffdb43d58
diff --git a/cluster/nix/modules/base.nix b/cluster/nix/modules/base.nix
index 84530c3..034d1cd 100644
--- a/cluster/nix/modules/base.nix
+++ b/cluster/nix/modules/base.nix
@@ -34,7 +34,16 @@
   programs.mtr.enable = true;
 
   networking.useDHCP = false;
-  networking.interfaces."${machine.mgmtIf}".useDHCP = true;
+  networking.interfaces."${machine.mgmtIf}" = {
+    ipv4.addresses = [
+      {
+        address = machine.ipAddr;
+        prefixLength = machine.ipAddrBits;
+      }
+    ];
+  };
+  networking.defaultGateway = machine.gw;
+  networking.nameservers = ["185.236.240.1"];
 
   # Instead of using nixpkgs from the root/nixos channel, use pkgs pin from this file.
   nix.nixPath = [ "nixpkgs=${pkgs.path}" "nixos-config=/etc/nixos/configuration.nix" ];