hswaw/machines/customs: add htpasswd file support, expose label

This allows for generic service access to hswaw LAN sites.

Change-Id: I2b290b19ae83496d6b878005ae1c57b0d3955e73
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1603
Reviewed-by: vuko <vuko@hackerspace.pl>
diff --git a/hswaw/machines/customs.hackerspace.pl/beyondspace.nix b/hswaw/machines/customs.hackerspace.pl/beyondspace.nix
index 90b17c0..02e677d 100644
--- a/hswaw/machines/customs.hackerspace.pl/beyondspace.nix
+++ b/hswaw/machines/customs.hackerspace.pl/beyondspace.nix
@@ -4,6 +4,7 @@
   beyondspaceDomains = {
     "inventory.waw.hackerspace.pl" = "https";
     "vending.waw.hackerspace.pl" = "https";
+    "label.waw.hackerspace.pl" = "http";
   };
 
 in with lib; {
@@ -15,6 +16,7 @@
     extraConfig = {
       oidc-issuer-url = "https://sso.hackerspace.pl";
       email-domain = "*";
+      htpasswd-file = "/var/beyondspace.htpasswd";
     };
   };