k0: enable fstrim, lower gc thresh for kubelet

fstrim is nice as it might prevent us from killing SSDs so fast.

A lower GC threshold for kubelet is nice as we run non-kubelet services
on these nodes, and they need their space. Notably, Ceph's mons tend to
be extremely claustrophobic, firing alerts at 70% disk usage or so.

Change-Id: I94c1787e62f82a02f107d04a87575327d3d79c01
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1724
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/cluster/machines/modules/kube-dataplane.nix b/cluster/machines/modules/kube-dataplane.nix
index 693d633..7e2066f 100644
--- a/cluster/machines/modules/kube-dataplane.nix
+++ b/cluster/machines/modules/kube-dataplane.nix
@@ -80,7 +80,9 @@
         clusterDns = "10.10.12.254";
         kubeconfig = pki.kube.kubelet.config;
         extraOpts = ''
-          --read-only-port=0
+          --read-only-port=0 \
+          --image-gc-high-threshold=60 \
+          --image-gc-low-threshold=40
         '';
         package = config.hscloud.kube.packageKubelet;
       };