cluster: bump vm.max_map_count sysctl tunable to a higher value

This is needed for running some memory-intensive workloads, like
ElasticSearch/OpenSearch.

Change-Id: I7b00ec5faca73ec69bdbf1ca41c025d7efeae55c
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1443
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/cluster/machines/modules/kubelet.nix b/cluster/machines/modules/kubelet.nix
index 1a71b48..79da4cb 100644
--- a/cluster/machines/modules/kubelet.nix
+++ b/cluster/machines/modules/kubelet.nix
@@ -303,7 +303,10 @@
       };
 
       boot.kernelModules = [ "br_netfilter" "overlay" ];
-      boot.kernel.sysctl."net.ipv4.ip_forward" = "1";
+      boot.kernel.sysctl = {
+        "net.ipv4.ip_forward" = "1";
+        "vm.max_map_count" = "262144"; # Needed for running things such as ElasticSearch.
+      };
 
       services.kubernetes.kubelet.hostname = with config.networking;
         mkDefault (hostName + optionalString (domain != null) ".${domain}");