ops/machines: pin edge01.waw to its current version of nixpkgs

Stopgap until we finish b/3, need to deploy some changes on it without
rebooting into newer nixpkgs.

Change-Id: Ic2690dfcb398a419338961c8fcbc7e604298977a
diff --git a/ops/machines.nix b/ops/machines.nix
index c341ec4..03cd541 100644
--- a/ops/machines.nix
+++ b/ops/machines.nix
@@ -6,12 +6,10 @@
 # Currently building/deployment is still done in a half-assed way:
 #
 #    machine=edge01.waw.bgp.wtf
-#    nix-build -A 'ops.machines."'$machine'"'.toplevel
+#    d=$(nix-build -A 'ops.machines."'$machine'"'.toplevel)
 #
-# This spits out a derivation path that correponds to the built config of that
-# machine. To deploy it:
+# To then deploy derivation $d on $machine:
 #
-#    d=/nix/store/nkdfoobarbazl0ybhazkmeyaylmaoqcr-nixos-system-edge01-20.09pre-git
 #    nix-copy-closure --to root@$machine $d
 #    ssh root@$machine $d/bin/switch-to-configuration
 #
@@ -35,7 +33,7 @@
     ];
   });
 
-  mkMachine = paths: pkgs.nixos ({ config, pkgs, ... }: {
+  mkMachine = pkgs: paths: pkgs.nixos ({ config, pkgs, ... }: {
     imports = paths;
   });
 
@@ -46,7 +44,16 @@
   "dcr01s22.hswaw.net" = mkClusterMachine "dcr01s22";
   "dcr01s24.hswaw.net" = mkClusterMachine "dcr01s24";
 
-  "edge01.waw.bgp.wtf" = mkMachine [
+  # edge01 still lives on an old nixpkgs checkout.
+  # TODO(b/3): unpin and deploy.
+  "edge01.waw.bgp.wtf" = mkMachine (
+    import (pkgs.fetchFromGitHub {
+      owner = "nixos";
+      repo = "nixpkgs-channels";
+      rev = "c59ea8b8a0e7f927e7291c14ea6cd1bd3a16ff38";
+      sha256 = "1ak7jqx94fjhc68xh1lh35kh3w3ndbadprrb762qgvcfb8351x8v";
+    }) {}
+  ) [
     ../bgpwtf/machines/edge01.waw.bgp.wtf.nix
     ../bgpwtf/machines/edge01.waw.bgp.wtf-hardware.nix
   ];