hswaw/machines/customs: check in code.hackerspace.pl/vuko/customs

Change-Id: Ic698cce2ef0060a54b195cf90574696b8be1eb0f
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1162
Reviewed-by: informatic <informatic@hackerspace.pl>
diff --git a/ops/machines.nix b/ops/machines.nix
index d0e6ae3..0a97bcd 100644
--- a/ops/machines.nix
+++ b/ops/machines.nix
@@ -52,6 +52,14 @@
     sha256 = "1ak7jqx94fjhc68xh1lh35kh3w3ndbadprrb762qgvcfb8351x8v";
   }) {};
 
+  # customs.hackerspace.pl migration temporary checkout
+  nixpkgsCustoms = import (pkgs.fetchFromGitHub {
+    owner = "nixos";
+    repo = "nixpkgs";
+    rev = "d12178b1c4a6ef1232c8c677573ba9db204e66ff";
+    sha256 = "0p7df7yzi35kblxr5ks0rxxp9cfh269g88xpj60sdhdjvfnn6cp7";
+  }) {};
+
   # Stopgap measure to import //cluster/nix machine definitions into new
   # //ops/ infrastructure.
   #
@@ -143,4 +151,8 @@
     ../bgpwtf/machines/edge01.waw.bgp.wtf.nix
     ../bgpwtf/machines/edge01.waw.bgp.wtf-hardware.nix
   ];
+
+  "customs.hackerspace.pl" = mkMachine nixpkgsCustoms [
+    ../hswaw/machines/customs.hackerspace.pl/configuration.nix
+  ];
 }