allow passing system to default.nix

This is needed to use hscloud in builds invoked from flakes.

Change-Id: I7551b97dfeedb9399866cd2c16cc573ee60359cc
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1452
Reviewed-by: q3k <q3k@hackerspace.pl>
diff --git a/default.nix b/default.nix
index 126e34c..07d1259 100644
--- a/default.nix
+++ b/default.nix
@@ -1,4 +1,4 @@
-{ ... }@args:
+{ system ? builtins.currentSystem, ... }@args:
 
 with builtins;
 
@@ -22,6 +22,7 @@
     config.permittedInsecurePackages = [
       "qtwebkit-5.212.0-alpha4"
     ];
+    inherit system;
   };
 
   resForPkgs = pkgs: fix (self: (readTree rec {