bgpwtf: edge01: bump nixpkgs, use networkd

Change-Id: I038f9518e090aecc90f464475f29c5b3c1570eff
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1339
Reviewed-by: implr <implr@hackerspace.pl>
diff --git a/bgpwtf/machines/modules/router.nix b/bgpwtf/machines/modules/router.nix
index 953b277..f476077 100644
--- a/bgpwtf/machines/modules/router.nix
+++ b/bgpwtf/machines/modules/router.nix
@@ -16,10 +16,11 @@
   environment.systemPackages = with pkgs; [
     tcpdump htop dstat file strace gdb mtr
     vim wget curl htop dstat whois bind
-    rxvt_unicode.terminfo dhcpcd efibootmgr
+    rxvt-unicode-unwrapped.terminfo dhcpcd efibootmgr
   ];
   networking.useDHCP = false;
   networking.firewall.enable = false;
+  networking.useNetworkd = true;
   boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
   boot.kernel.sysctl."net.ipv4.conf.*.accept_redirects" = 0;
   boot.kernel.sysctl."net.ipv4.conf.*.send_redirects" = 0;