hswaw/machines/customs: rework checkinator build

Change-Id: I4ec569c5966f65f46f48a3707842a1fe9d483e16
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1171
Reviewed-by: informatic <informatic@hackerspace.pl>
diff --git a/hswaw/machines/customs.hackerspace.pl/checkinator-tracker.nix b/hswaw/machines/customs.hackerspace.pl/checkinator-tracker.nix
index 74617c7..17a9b17 100644
--- a/hswaw/machines/customs.hackerspace.pl/checkinator-tracker.nix
+++ b/hswaw/machines/customs.hackerspace.pl/checkinator-tracker.nix
@@ -1,14 +1,7 @@
 { pkgs, ... }:
 
 let
-  old-pkgs = import (fetchTarball {
-    sha256 = "0kdx3pz0l422d0vvvj3h8mnq65jcg2scb13dc1z1lg2a8cln842z";
-    url = https://api.github.com/repos/NixOS/nixpkgs/tarball/0bf298df24f721a7f85c580339fb7eeff64b927c;
-  }) { config = pkgs.config; };
-
-  repo = pkgs.fetchgit (builtins.fromJSON
-    (builtins.readFile ./checkinator-repo.json));
-  checkinator = old-pkgs.callPackage "${repo}/default.nix" {};
+  checkinator = pkgs.callPackage ./checkinator.nix {};
 
   name = "checkinator-tracker";
   user = name;