hswaw/machines: add tv1, larrythebuilder

This adds two brand new AArch64 machines: a generic builder (and
instructions on how to use it) and tv1.waw, an RPi4 acting as digital
signage in the space.

Change-Id: I8d38344ec35f99f4b872cf9526f6e6771fbffc43
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1330
Reviewed-by: informatic <informatic@hackerspace.pl>
diff --git a/ops/machines.nix b/ops/machines.nix
index 208279e..5a7d3d7 100644
--- a/ops/machines.nix
+++ b/ops/machines.nix
@@ -134,6 +134,10 @@
     path
   ];
 
+  pkgsArm = import pkgs.path {
+    system = "aarch64-linux";
+  };
+
   machines = self: {
     "bc01n01.hswaw.net" = mkClusterMachine self ../cluster/machines/bc01n01.hswaw.net.nix;
     "bc01n02.hswaw.net" = mkClusterMachine self ../cluster/machines/bc01n02.hswaw.net.nix;
@@ -145,9 +149,16 @@
       ../bgpwtf/machines/edge01.waw.bgp.wtf-hardware.nix
     ];
 
+    "larrythebuilder.q3k.org" = mkMachine self pkgsArm [
+      ../hswaw/machines/larrythebuilder.q3k.org/configuration.nix
+    ];
+
     "customs.hackerspace.pl" = mkMachine self pkgs [
       ../hswaw/machines/customs.hackerspace.pl/configuration.nix
     ];
+    "tv1.waw.hackerspace.pl" = mkMachine self pkgsArm [
+      ../hswaw/machines/tv1.waw.hackerspace.pl/configuration.nix
+    ];
   };
 
 in pkgs.lib.fix machines