shell.nix: add git to targetPkgs

nix-shell attempts to use packages from the system and fails to find git
installed via users.users.<name>.packages.  Adding it to targetPkgs
resolves the issue and makes the dependency explicit.

Change-Id: Ie0c3e48065174a5032ced9c31236f65255483d08
diff --git a/shell.nix b/shell.nix
index 1b504cf..de3db3c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -27,6 +27,7 @@
     gcc binutils
     pwgen
     tmate
+    git
   ];
   multiPkgs = pkgs: [
     (pkgs.runCommand "protocols" {}