cluster: k0: remove native ceph

After installing HBJ11s and spreading out the mons we're going full
Rook.

Change-Id: Ia00cbe953548f06cf27343371fc67890619c8262
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1466
Reviewed-by: q3k <q3k@hackerspace.pl>
diff --git a/ops/machines.nix b/ops/machines.nix
index 7261ce8..10b5d4f 100644
--- a/ops/machines.nix
+++ b/ops/machines.nix
@@ -19,28 +19,7 @@
     repo = "nixpkgs-channels";
     rev = "44ad80ab1036c5cc83ada4bfa451dac9939f2a10";
     sha256 = "1b61nzvy0d46cspy07szkc0rggacxiqg9v1py27pkqpj7rvawfsk";
-  }) {
-    overlays = [
-      (self: super: rec {
-        # Use a newer version of Ceph (16, Pacific, EOL 2023-06-01) than in
-        # this nixpkgs (15, Octopus, EOL 2022-06-01).
-        #
-        # This is to:
-        #  1. Fix a bug in which ceph-volume lvm create fails due to a rocksdb
-        #     mismatch (https://tracker.ceph.com/issues/49815)
-        #  2. At the time of deployment not start out with an ancient version
-        #     of Ceph.
-        #
-        # Once we unpin nixpkgsCluster past a version that contains this Ceph,
-        # this can be unoverlayed.
-        inherit (super.callPackages ./ceph {
-          boost = super.boost17x.override { enablePython = true; python = super.python3; };
-          lua = super.lua5_4;
-        }) ceph ceph-client;
-        ceph-lib = ceph.lib;
-      })
-    ];
-  };
+  }) { };
 
   # mkMachine builds NixOS modules into a NixOS derivation.
   # It:
@@ -112,7 +91,6 @@
     ../cluster/machines/modules/base.nix
     ../cluster/machines/modules/kube-controlplane.nix
     ../cluster/machines/modules/kube-dataplane.nix
-    ../cluster/machines/modules/ceph.nix
     path
   ];
 
@@ -120,7 +98,6 @@
     ../cluster/machines/modules/base.nix
     ../cluster/machines/modules/kube-controlplane.nix
     ../cluster/machines/modules/kube-dataplane.nix
-    ../cluster/machines/modules/ceph.nix
     path
   ];