Make golang deps fetching go faster

This commit aims to increase the speed of hscloud rebuild process
by optimizing the behavior of Go dependency fetching routines.

Gazelle v0.25.0 introduced a new dependency resolution mode
where it does not reach out for external dependencies; instead,
it operates solely on what is contained inside the workspace.

Because static dependency resolution mode is now the default
behavior in go_repository() rules, we are also updating the
contents of //third_party/go/repositories.bzl.

Also, I changed some of the bigger Go dependencies to be downloaded
by a tarball fetch in order to speed up the rebuild process.

Other changes:
  * Bump nixpkgs to a fresh snapshot
  * Upgrade to Bazel v5

Change-Id: Icfe752411b3128bcd5b25fa28bb76bec45ae2f71
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1441
Reviewed-by: q3k <q3k@hackerspace.pl>
diff --git a/shell.nix b/shell.nix
index 5dd597b..f20cbb0 100644
--- a/shell.nix
+++ b/shell.nix
@@ -42,7 +42,7 @@
 in (pkgs.buildFHSUserEnv {
   name = "hscloud-build";
   targetPkgs = pkgs: with pkgs; [
-    bazel_4
+    bazel_5
     postgresql
     python38
     openjdk11