bgpwtf: peer with cloudflare

Change-Id: I00d040d56610b965d03d5af5cf7f17a5ea7f7b2d
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1484
Reviewed-by: q3k <q3k@hackerspace.pl>
diff --git a/bgpwtf/machines/edge01.waw.bgp.wtf.nix b/bgpwtf/machines/edge01.waw.bgp.wtf.nix
index c541bed..afcd60e 100644
--- a/bgpwtf/machines/edge01.waw.bgp.wtf.nix
+++ b/bgpwtf/machines/edge01.waw.bgp.wtf.nix
@@ -334,6 +334,17 @@
       filterIn = filterInUpstream;
       filterOut = filterOutUpstream;
     };
+    "waw_cloudflare" = {
+      description = "PEER Cloudflare AS13335 (EPIX)";
+      table = "internet";
+      local = "89.46.145.61";
+      neighbors = [
+        { address = "89.46.144.83"; asn = 13335; password = passwords."edge01.waw-bgp-cloudflare"; }
+      ];
+      prepend = 0; pref = 300;
+      filterIn = filterInUpstream;
+      filterOut = filterOutUpstream;
+    };
     # hscloud spine switch (dcsw01.hswaw.net).
     "waw_hscloud" = {
       description = "AGGREGATE CUSTOMER hscloud/dcsw01";
@@ -445,6 +456,17 @@
       filterIn = filterInUpstream;
       filterOut = filterOutUpstream;
     };
+    "waw_cloudflare" = {
+      description = "PEER Cloudflare AS13335 (EPIX)";
+      table = "internet";
+      local = "2001:678:3ac::313";
+      neighbors = [
+        { address = "2001:678:3ac::83"; asn = 13335; password = passwords."edge01.waw-bgp-cloudflare"; }
+      ];
+      prepend = 0; pref = 300;
+      filterIn = filterInUpstream;
+      filterOut = filterOutUpstream;
+    };
     # hscloud spine switch (dcsw01.hswaw.net).
     "waw_hscloud" = {
       description = "AGGREGATE CUSTOMER dcsw01.hswaw.net";