signage: bring in from external repo

This is b28e6f07aa48f1e2f01eb37bffa180f97a7b03bd from
https://code.hackerspace.pl/q3k/love2d-signage/. We only keep code
commited by inf and q3k, and we're both now licensing this code under
the ISC license, as per COPYING in the root of hscloud.

Change-Id: Ibeee2e6923605e4b1a17a1d295867c056863ef59
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1335
Reviewed-by: informatic <informatic@hackerspace.pl>
Reviewed-by: q3k <q3k@hackerspace.pl>
diff --git a/hswaw/machines/tv/common.nix b/hswaw/machines/tv/common.nix
index c1b8e7c..228d780 100644
--- a/hswaw/machines/tv/common.nix
+++ b/hswaw/machines/tv/common.nix
@@ -1,6 +1,6 @@
 # RPi4 as TV kiosk.
 
-{ config, pkgs, ... }:
+{ config, pkgs, workspace, ... }:
 
 let
   nixos-hardware = builtins.fetchGit {
@@ -32,12 +32,6 @@
   networking.domain = "waw.hackerspace.pl";
   time.timeZone = "Europe/Warsaw";
 
-  nixpkgs.overlays = [
-    (self: super: {
-      signage = self.callPackage ./signage.nix {};
-    })
-  ];
-
   sound.enable = true;
   services.pipewire = {
     enable = true;
@@ -107,7 +101,7 @@
        '';
     in pkgs.writeScriptBin "signage-wrapped" ''
       #!/usr/bin/env bash
-      SIGNAGE_CONFIG=${config} ${signage}/bin/signage
+      SIGNAGE_CONFIG=${config} ${workspace.hswaw.signage.prod}/bin/signage
     '')
     firefox foot wayvnc
     vim rxvt-unicode-unwrapped.terminfo