cluster/nix: k0: enable rgw on osds

This enables radosgw wherever osds are. This should be fast and works
for us because we have little osd hosts.

Change-Id: I4ed014d2790d6c02a2ba8e775aaa1846032dee1e
diff --git a/cluster/nix/modules/ceph.nix b/cluster/nix/modules/ceph.nix
index bc3180f..c258f5b 100644
--- a/cluster/nix/modules/ceph.nix
+++ b/cluster/nix/modules/ceph.nix
@@ -51,6 +51,10 @@
       enable = true;
       daemons = map (el: "${toString el.id}") cephCluster.osds.${machineName};
     };
+    rgw = {
+      enable = true;
+      daemons = [ "rook-k0.rgw.${machineName}" ];
+    };
   } else {};
 
   # The full option fragment for services.ceph. It contains ceph.conf fragments